**** Advance Notice ****

This site will be closed on 31 December 2015,

Important Information for users of NXP LPCXpresso

This site is for users of Code Red branded products.

NXP LPCXpresso users should visit the LPCXpresso FAQ's for up-to-date information relevant to that product.

Error while launching command: gdb --version

When using the Code Red IDE version 5 you may receive the following error when starting a debug session

Error while launching command: gdb --version

Cause

This is caused by selecting the wrong type of Launch (Debug) configuration. If you use the Quickstart Debug button, the correct configuration is automatically chosen. However, if you are creating your own configuration you MUST use C/C++ (Code Red) MCU Application.

How to fix

First, you must delete the existing Launch configuration. You can do this in one of two ways

  1. Right-click on the project in the Project Explorer and select Launch Configurations->Delete Current; OR

  2. Open the Debug Configurations dialog and delete from within there:
    • Right-click on the project in the Project Explorer and select Launch Configurations->Edit Current

    • Find the configuration(s) for you project and delete them by selecting them and pressing the red X in the toolbar

The is more information on this see the Launch Configuration Menu FAQ.

Next, create a new Launch configuration. The recommended way of creating a Launch configuration is to select the project in Project Explorer and press the Debug button in the Quickstart panel.

For Advanced users, you can create your own Launch configuration in the Debug Configurations dialog and create a new configuration using the C/C++ (Code Red) MCU Application type. But generally, there is no need to do it this way, and you should use the Quickstart Debug button.

ErrorLaunchingGDBVersion (last edited 2013-03-28 10:08:07 by CrSupportAb)